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  Welcome to Phaser  

Thank you for considering Phaser as an addition to your Desktop. 

Phaser provides a powerful, yet inviting, computing environment specifically crafted for the graphical and 
numerical simulations of differential and difference equations, from linear to chaotic. 

Phaser has been designed to meet the needs of a wide variety of users whether they be general chaos 
enthusiasts, students, instructors, or researchers. Written in pure Java, Phaser can be used on multiple 
platforms, or to share projects freely across platforms. 

Chaos enthusiasts will appreciate Phaser's unprecedented ease of use, with graphics purposely set up to 
enhance the pleasures of learning about chaos and fractals. They will enjoy lively demonstrations revealing 
the dynamics of landmark equations. 

Students will exploit Phaser's potential to manipulate standard textbook examples and exercises in order to 
achieve a better understanding of differential equations and their applications. They will find Phaser's step-by-
step tutorials particularly useful. Instructors of undergraduate and graduate classes will be pleased to learn 
that Phaser provides powerful media specifically designed for effective classroom or laboratory 
presentations. The Phaser Project environment and the Gallery can be used to store, retrieve and animate a 
variety of demonstration elements. Instructors will also appreciate that Phaser includes a comprehensive, 
expandable, library of equations and a reference guide to computational dynamical systems. 

Researchers in fields as diverse as biology, chemistry, economics, engineering, mathematics, and physics 
will find Phaser an invaluable tool in their quest to visualize quantitative models quickly and accurately. An 
equation editor allows new equations to be entered without programming. State-of-the-art numerical 
algorithms provide research-grade results with completely configurable error controls. Phaser's fingertip 
controls allow for rapid exploration of global dynamics and bifurcations, as well as for the sharing of 
research findings across the Internet. 

In the succeeding pages you will find a brief overview of Phaser and some guidance to help you quickly 
experience Phaser's user-friendly computing environment. Afterwords, with the assistance of the Tutorials, 
you are invited to explore some of the more prominent capabilities of Phaser. 

3



  Customer Support  

Phaser support team provides several forms of technical assistance: 

●     Visit our main Web site www.phaser.com and consult FAQs (Frequently Asked Questions) and 
troubleshooting information that provides answers to common problems. 

●     Read tips from the menu item Help -> Tips. 

●     Consult PhaserHelp from the menu item Help -> Help Contents. In PhaserHelp, browse Index or 
Search for key words. 

●     E-mail your Phaser questions to support@phaser.com. In your correspondence, please provide 
system information which can be gathered from the menu item Help -> System Information. 

●     Register at www.phaser.com to receive occasional Phaser news. 

4

http://www.phaser.com/index.html
mailto:support@phaser.com
http://www.phaser.com/index.html


  Licenses  

License Agreement

A copy of Phaser purchased either on a CD or downloaded from our Web site www.phaser.com is for 
personal use on a single computer. To install Phaser on your computer, you are required to agree to the terms 
and conditions of the Phaser License Agreement. 

  

Site License

If Phaser will be used on multiple computers or by multiple users, a site license must be obtained. To 
accomodate varying needs, several levels of site licencing are available. Please visit our Web site www.
phaser.com for futher details of site licensing Phaser, and the terms and conditions of the Phaser Site License 

Agreement. If you require further information or terms customized for your needs, please contact us at 
info@phaser.com. 

  

Sun Microsystems Binary Code Agreement

As part of the Phaser installation setup, a copy of Java Runtime Environment (JRE) may be installed on your 
computer, if an appropriate JRE is not already present. In this case, you must also agree to read and abide by 
the terms and conditions of the Binary Code License Agreement for the JAVA SE RUNTIME 
ENVIRONMENT (JRE) VERSION 6 of Sun Microsystems, Inc.; see, for example, http://java.sun.com/
javase/6/jre-6u1-license.txt. 

Additional information on Sun Microsystems Licensing and Terms of Use details can be found at http://www.
sun.com/termsofuse.html/ 
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  Startup  

Main: In this section we describe the startup screen layout of Phaser and establish a common terminology for 
its graphical user interface. When the loading of Phaser is completed, you should see the PHASER Main 
Application window as displayed below. 

 

Main Application Window: PHASER

The Main Application window consists of several panels with the following components and functions: 

Title Bar 
This is the top bar containing the title PHASER of the main application window. 
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Menu Bar 
Below the title bar is the menu bar containing pull-down menus File, Edit, View, Equation, 
Phaser, and Help. 

Button Bar 
This is the row of buttons labeled <<, >>, Go, Clear, Suspend, Stop, Numerics. 

Banner 
This is the area which contains the current equation name, Pendulum ODE, and the current view 
name, Phase Portrait. As the current equation or the current view is changed the banner is 
updated. The colorful Phaser icon button in the center is used to access the Phaser Gallery. 

View 
This is the large, black graphical display area containing axes and grids. The current view is 
Phase Portrait; the view can be changed from the View pull-down menu on the menu bar, or 
they can be cycled with the << and >> buttons on the Button Bar. 

Tool Bar 
This is the panel immediately below the Phase Portrait view and it serves a dual purpose. The left 
portion is for status of mouse cursor location in the graphical view. The central choice button IC is 
a mouse action selector for using the mouse to set Initial Conditions, Zoom, Pan, 3-D rotations, or 
Flow. The right portion of the Tool Bar is dedicated for configuring the current mouse function. 

Progress Bar 
This is the last panel of the Main Application window which displays a progress bar and a 
percentage meter to monitor the status of the computations after the Go button is clicked. 
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Co-primary Window: PHASER: Numerics Editor

Numerics Editor: Now, if you press the Numerics button on the Button Bar of the main application 
window, a new co-primary window titled PHASER: Numerics Editor is spawned. This co-primary window is 
the "bridge" or command center of Phaser. The Numerics Editor window has the following panels: 

Title Bar 
This is the top bar containing the title PHASER: Numerics Editor of the co-primary window. You 
can click on it to bring the window to the foreground if it is partially hidden. 

Menu Bar 
This is the bar containing the pull-down menus File, Edit, View, and Help. 

Button Bar 
This bar contains the buttons Current View, Initial Conditions, Parameters, 
Time, and Algorithms. Each one of these buttons brings up a sub-editor which is displayed in 
the large center panel. 
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Banner 
It displays the name of the selected button from the button bar. In the case Current View is 
selected, it displays the name of the current view (e.g. Phase Portrait). 

Center Panel 
The large panel in the center of the Numerics Editor window contains the appropriate sub-editor 
requested by one of the buttons on the button bar. Most of these sub-editors contain two main 
components. The first component on the left is a tree whose nodes contain various choices grouped 
together in a cohesive manner. The choices for each node are listed in the right portion of the central 
panel. 

Status Field 
This is the elongated box in the bottom left corner which contains the word ``Ready.'' This field 
provides feedback on the actions requested. 

Action Buttons 
These are the four buttons, Console, Phaser, Apply, and Revert, in the lower-right 
corner. 
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  Browsing  

Phaser is equipped with extensive libraries of equations of historical, scientific, or aesthetic appeal. Each 
equation comes with default settings that result in an informative picture. Here is how you can view these 
default pictures and get a first impression of some of the basic capabilities of Phaser. 

Pendulum ODE

When Phaser starts, the default equation is Pendulum ODE. To see a partial phase portrait of the classical 
planar pendulum without friction, select the menu item 

Equation → Load Equation Defaults 

 

Phase portrait of Pendulum ODE

For additional solutions, click the left mouse button at desired points on the black region and press Go. 
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PhaserHelp

You can now view the page of PhaserHelp containing the mathematical equations, and thumbnail sketches of 
dynamical and physical highlights of the Pendulum ODE: select the menu item 

Equation → View Current Equation Help 

 

PhaserHelp entry for Pendulum ODE

PhaserHelp comprises an extensive online manual. In addition to mathematical, computational, and 
experimental information about each Library Equation, it contains detailed specifications of all Phaser 
commands, implemetation details of algorithms, Tutorials, and a collection of Tips for common and 
uncommon tasks. PhaserHelp can be launched by selecting the menu item 

Help → Help Contents 

and the desired information can easily be located using Table of Contents, Index, or searchable text. 
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Lorenz ODE

To load the famous Lorenz equations from the Phaser ODE Library and compute a pair of non-periodic 
solutions (one in blue and the other in yellow) in 3-D, select the menu items: 

Equation → ODE Library → Lorenz ODE 
Equation → Load Equation Defaults 

 

Two nonperiodic solutions of the Lorenz Equations

The mouse can be configured for several different functions in Phaser. For instance, in the Pendulum ODE 
simulation, it was set to select new initial conditions (IC). In the Equation Defaults of Lorenz ODE, the 
mouse is configured to rotate the image in three dimensions. This is indicated as 3-D in the mouse slector 
widget in the center of the tool bar. Now, grab the image with your mouse and rotate it while holding down 
the left mouse button. The radio buttons on the tool bar can be used for more precise animations of the 
image. 
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Symmetric Icons MAP

Results of Phaser simulations can be saved and shared over the Internet. If you have a reasonably fast 
connection, you can download and view a gallery of interesting images from our Web site by doing the 
following: 

Phaser → Gallery         and from the spawned window, select

File → Load Gallery URL         in the spawned dialog box, type

http://www.phaser.com/projects/icons.pgf         and hit 

Fetch 

 

Fetching a Phaser Gallery over the Internet
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  Now, click on a frame (boundary should turn red) and select Phaserize to see the small image loaded and 
computed in the Phaser main view. 

 

Sanddollar as the attractor of a 2-D MAP

If you are curious which mathematical formula generates such a natural picture, select the menu item 

Equation → View Current Equation Help 
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  Interacting with Phaser  

Here, general guidelines for interacting with Phaser are outlined in rather broad brush strokes. Detailed 
implementations of these guidelines are provided in Tutorials. 

Selecting Equation: After launching Phaser, the first task is to select an equation from the permanent 
libraries, MAP Library or ODE Library, for numerical simulations. If the desired equation is not in the 
libraries, it can easily be entered as a Custom Equation using Phaser's Equation Editor. These options can be 
executed from the Equation menu located on the menu bar of the Main Application window. 

Selecting View: The second task is to choose a graphical view appropriate for the intended study of the 
current equation. This can be accomplished from the View menu on the menu bar of the Main Application 
window. Alternatively, one can cycle through the views using the   <<   or   >>   buttons on the button bar of 
the Main Application window. Currently, there are five graphical views: 

●     Phase Portrait View: Two- or three-dimensional projections of orbits are plotted here. In 
three dimensions or higher, orbits can be rotated in real time. Flows, vector fields, and Poincaré 
maps can also be displayed. 

●     Xi vs Time View: Selected Xi variables vs. Time are plotted here. In dimension one, direction 
fields can be superimposed. 

●     Bifurcation Diagram View: One of the variables versus a parameter can be plotted to 
investigate possible bifurcations. 

●     1-D Stair Stepper View: Stair-step or cobweb diagrams of orbits of one-dimensional maps 
can be plotted in this view. 

●     Xi Values View: Computed numerical values of the Xi variables are tabulated here. 

Numerics Editor: The third task is to configure the graphical display options for the current view and to fix 
the setting for numerical computations of solutions. These multitude of choices are made from Numerics 
Editor housed in the co-primary window. This window can be brought to the foreground by clicking on the 
Numerics button on the button bar of the Main Application window. Numerics Editor has the following 
five important buttons on its button bar: 

●     Current View: To configure the current graphical view; e.g. Window size. Each graphical view 
has its private set of options. 

●     Initial Conditions: To specify the values and colors of multiple initial conditions whose 
solutions are computed simultaneously and processed for the current view. Initial conditions can 
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also be entered by clicking the mouse at the desired locations in the current graphical view. 

●     Parameters: To set the values of the parameters in the current equation. 

●     Time: To set the duration of computations of solutions. 

●     Algorithms: To select the current algorithm and its control settings to be used in numerical 
computations of solutions. 

Local and Global Settings: The configuration set by Current View is local in the sense that it applies 
only to the current view and is independent of the configurations of the other views. Consequently, each view 
must be configured individually. The remaining items set using Initial Conditions, Parameters, 
Time, and Algorithms are global and used in all views. If a new equation is chosen, some of the global 
settings are set to their default values. 

Apply: Choices made or the numbers typed into text fields in Numerics Editor do not take effect unless the 
Apply button of the Editor is clicked. APPLY! 

Mouse: When the cursor is within a graphical view, the mouse can be used for several different actions, such 
as setting Initial Conditions (IC), Zoom In/Out, Pan, 3-D Rotations, or Flow. The drop-down choice widget 
in the center of the task bar is the mouse action selector. 

Save, Restore, and Gallery: Obtaining an informative or pleasing image of a dynamical phenomenon can 
require extensive experimentation involving many settings of the graphical and numerical choices. The entire 
state of Phaser necessary to recreate an image can be saved using the Save Current Project entry of 
the File menu of the Main Application Window. Collections of images can be exhibited in the Gallery. 

Help: The contents and the index of online Help are searchable. Detailed information about a particular 
Phaser function, or technical and scientific information about an equation in the Library can easily be 
located. 
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  Tutorials  

The sequence of lessons below are designed to guide the user, step by step, through some of the basic 
capabilities of Phaser. In these lessons, it is assumed that Phaser is in the start up configuration, and that 
values of all things are set to the defaults. Therefore, before starting each lesson, either Phaser should be 
restarted or Preferences should be set to System Defaults. 

Lesson 1. First Steps: Computing e 
A must Lesson for getting started. 

Lesson 2. Xi vs. Time 
Using the Logistic differential equation (ODE), how to display solutions on the Xi vs Time plane, 
drawing direction fields. 

Lesson 3. Stair-Step Diagrams 
Using the Logistic difference equation (MAP), how to display stair-step diagrams. 

Lesson 4. Bifurcation Diagram of Logistic MAP 
How to compute bifurcation diagram of this famous map. Zoom in and out of regions of the 
bifurcation diagram. 

Lesson 5. Phaser Projects 
How to save a current state of Phaser, reload it later, or share it over the net. 

Lesson 6. The Gallery 
How to create a gallery of live images and their animations. 

Lesson 7. Custom Library: Entering your equations 
How to enter or modify your own ODE or MAP into the Custom Library of Phaser. All done with 
an easy-to-use Equation Editor. 

Lesson 8. Flow box 
How to follow 5000 solutions, starting from a selected box, simultaneously. 

Lesson 9. Cloning Current Phaser 
How to spawn a new Phaser and run two copies simultaneously. An unforgettable example from 
chaotic numerics. 

Lesson 10. Real-Time 3-D Graphics 
How to twirl around 3-D orbits in real time. 
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Lesson 11. Poincaré Map in 3-D 
How to slice an orbit in 3-D with any plane, and compute the points of intersection on the plane in 
one or both directions. 

Lesson 12. Poincaré Map of Forced Duffing ODE 
How to compute Poincaré maps of periodically forced second-order oscillators. Periodic and non-
periodic orbits of Forced Duffing are used as examples. 

Lesson 13. Sequencing Slides 
How to generate a sequence of slides. As an example, a sequence of fractal curves with dimensions 
from 1 to 1.9 in increments of 0.1 are generated. 

18



Lesson 1. First Steps: Calculating e 

We commence our lessons with Phaser using a simple but delightful example. Let us consider the initial-
value problem 
   .
   x = x ,      x(0) = 1 

and determine numerically x(1.0), the value of the solution at t = 1.0. The solution of this elementary 
problem is the exponential function x(t) = et. Thus the desired value x(1) is the famous number e. The value 
of e can be found with a decent pocket calculator to be 

  e = 2.718281828459045...   . 

In this lesson, we will numerically integrate the initial-value problem above, to compute the value of e. This 
may appear to be pedantic but having this number in our possession will permit us to test the accuracy of our 
numerical integrator on this initial-value problem. 

»> Equation -> ODE Library -> Cubic 1-D ODE: 
The first task is to specify the equation we would like to study. To get our differential equation, 
click on the Equation menu on the menu bar of the Main Application window, and select ODE 
Library. From the list of ODEs (Ordinary Differential Equations), select Cubic 1-D ODE. 
Notice that the banner is now updated to display the name of the current equation. Cubic 1-D 
ODE is a general purpose one-dimensional differential equation, but what does it look like? 

»> Equation -> View Current Equation Text: 
From Equation menu, select the View Current Equation Text. A small window 
containing the text of Cubic 1-D ODE should pop. In the text 
   .
   x1 = a + b x1 + c x1

2 + d x1
3,

a, b, c, and d are changeable parameters and x1 is the variable. We will momentarily set the 

appropriate parameter values to get our differential equation. 

»> Numerics: 
In preparation for setting the desired parameter values, click on the Numerics button on the button 
bar of the Main Application Window. This displays the Numerics co-primary window. 

»> Parameters: 
Click on the Parameters button on the button bar of Numerics Editor. The four parameters and 
their current default values are now visible. We need to set a=0, b=1, c=0, and d=0 to obtain our 
differential equation from Cubic 1-D ODE. Now, click in the text field containing the value of 
b, which currently is -1.0, and change it to 1.0. There are several convenient ways to change text 
fields: click after a character you would like to change and use the backspace key, or double click 
anywhere in the field to highlight the field and type your new characters. We can leave the other 
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parameter values as they are. Notice the (modified) token on the banner and Status Field of 
Numerics Editor signaling the fact that a current setting has been modified. 

»> Apply: 
Click on the Apply action button on the lower-right corner of Numerics Editor for these new 
parameter values to take effect. Notice that the (modified) token on the banner of Numerics 
Editor has disappeared, signaling that the new values of the parameters have been registered. Status 
Field in the lower-left corner of Numerics Editor now indicates Ready. 

»> Initial Conditions: 
Click the Initial Conditions button on the button bar of Numerics Editor. Notice that there 
is one set of initial conditions activated with the default values t = 0.0 and x1 = 1.0. These values 

happen to be what we want; so we will not touch them. 

»> Time: 
Click the Time button on the button bar of Numerics Editor. Notice that the Start Plotting 
time is set to 0.0, and the Stop Plotting time is set to 20.0. Time is relative; that is, the 
solution from the initial time will be computed and displayed for 20 time units in the forward 
direction. Since we want to see the value of the solution at t = 1.0, we set Stop Plotting to 1.0, 
and APPLY. 

»> Main Application Window: 
Click on the title bar of the Main Application window to bring the main window to the foreground. 
You can also click on the Phaser action button on the lower right-hand corner of the Numerics 
Editor to accomplish the same task. 

»> View -> Xi Values: 
From the View menu of the Main Application window select Xi Values. Now the current view 
is set to Xi Values which is the appropriate view for tabulating numerical values of solutions. 

»> Go: 
After this extensive preparation, now click on the Go button on the button bar of the Main 
Application window to see the results. The last line is the computed value of x1 at time 1, that is, 

2.7182818285E+000. Notice that this output is in scientific notation, which is the output format 
used in Phaser. Also, it is interesting to observe that the last digit has been rounded up by the 
compiler. 
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Lesson 2. Xi vs. Time 

In this lesson, we will learn how to customize the Xi vs. Time view, while investigating the dynamics of 
a single population modeled with the logistic differential equation 
   .
   x = x - x2. 

Here x(t) represents the population density as a function of time. The qualitative dynamics of this differential 
equation are rather simple. The equation has two equilibrium states: x(t) = 0.0 and x(t) = 1.0. The first 
equilibrium is not of much ecological interest as it corresponds to zero population density. The second 
equilibrium, however, is of paramount importance because the solution from any positive initial condition 
approaches 1.0 as time increases. This positive limiting equilibrium density is the carrying capacity of the 
population. We shall see now the approach to the carrying capacity as time goes on. 

»> Equation -> ODE Library -> Cubic 1-D ODE: 
To get our differential equation, click on the Equation menu on the menu bar and select the ODE 
Library. From the list of ODEs, select Cubic 1-D ODE. 

»> Equation -> View Current Equation Text: 
From the Equation menu, select View Current Equation Text. A small window 
containing the text of Cubic 1-D ODE should pop. In the text
.
x1 = a + b x1 + c x1

2 + d x1
3,

a, b, c, and d are changeable parameters and x1 is the variable. We will next adjust the parameter 

values to set our logistic differential equation. 

»> Numerics: 
In preparation for setting the desired parameter values, click on the Numerics button on the button 
bar of the Main Application Window. This displays the Numerics co-primary window. 

»> Parameters: 
Click on the Parameters button on the button bar of the Numerics Editor. The four parameters 
and their current default values are now visible. We need to set a = 0, b = 1, c = -1, and d = 0 to 
obtain our logistic differential equation from Cubic 1-D ODE. Now, click in the text field 
containing the value of b and change it to 1.0. Next, click in the text field containing the value of c 
and change it to -1.0. Notice the (modified) token on the banner and the Status Field of the 
Numerics Editor. 

»> Apply: 
Click on the Apply button on the lower right corner of the Numerics Editor for these new 
parameter values to take effect. Notice that the (modified) token on the banner of the Numerics 
Editor has disappeared. 
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»> Initial Conditions: 
Click the Initial Conditions button on the button bar of the Numerics Editor. Notice that 
there is one set of initial conditions activated with the default values t = 0.0 and x1 = 1.0. 
These values happen to be the equilibrium state corresponding to the carrying capacity. Let us add 
two more initial conditions. 

»> Set 2 and Set 3: 
To activate the second set of Initial Conditions, click on the left-most button next to Set 2. This 
should highlight the first two text fields, the first of which is the initial time and the second of which 
is the initial x1 value. Change the value of x1 to 0.1. In Set 3 set x1 to 1.5. Apply. 

»> Phaser: 
Click on the Phaser action button to return to the Main Application Window. 

»> View -> Xi vs Time: 
Return to the Main Application Window by clicking on its title bar. From the View menu of select 
Xi vs Time. Now the current view is set to Xi vs Time. Vertical Axis will house the x1 
variable and the horizontal axis will house time. 

»> Go: 
Now press Go and watch the three solutions being plotted simultaneously. 

This picture is adequate, but we can do better. Let us now return to the Numerics Editor and fine tune the Xi 
vs Time view. 

»> Current View -> Window Size: 
Click on the Current View button and from the control tree choose Window Size. Set X-Min 
= -1, X-Max = 5, Y-Min = -1, and Y-Max = 2. Apply. Notice that the Xi vs Time view is cleared 
and Axes and Grids are redrawn. 

»> Axes and Grids: 
From the control tree choose Axes and Grids, then set the last two text fields, X- and Y- 
Grid Gap Values, to 0.2. Apply. Grids are now redrawn with the new gap sizes. 

»> Graphics: 
Click on the Graphics node on the control tree. The first entry on the right is Graph Point 
Size which sets the size of the points used in the plotting of the solutions. Click on the drop-down 
widget (small bar to the left of entry) and from the list choose 3. 

»> Direction Field: 
From the control tree choose Direction Field and press the left-most small square on the first 
line. Apply. Now, along with the solutions, the Direction Field will be drawn at grid points when we 
press Go. 

»> Time: 
Click the Time button on the button bar of the Numerics Editor. Set Start Plotting to -6.0, 
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and the Stop Plotting time to 6.0. The solutions will be computed backwards for 6 time units 
and then computed forwards for another 6 time units. Apply. 

»> Go: 
Return to the Main Application window and press Go to see the result. Messages from the current 
numerical algorithm used to generate solutions appear in the Numerics Console co-primary 
window. Notice that the solution starting from Initial Condition Set 3, which blows up in backward 
time, has been stopped by the Dormand-Prince 5(4) algorithm as it cannot meet the set error 
tolerances. 

»> Finale: 
Press Clear. Click the mouse in about a dozen different locations inside the Xi vs Time view and 
press Go. 
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Lesson 3. Stair-Step Diagrams 

Orbits of one-dimensional difference equations can be best followed using a geometric method known as 
Stair-Step, or cobweb, diagram. In this lesson, we will learn how to use this method while exploring the 
dynamics of decidedly the most famous one-dimensional difference equation, the Logistic MAP 

 
Stair-step diagrams: Here is how a stair-step diagram of a solution of a difference equation x1 -> f (x1) is 

computed. We first draw the 45-degree line through the origin and the graph of f. Then, for an initial value of 
x1 on the horizontal axis, we find next x1 by drawing the vertical line segment from the initial point until it 

meets the graph of f. Now, to transfer the vertical coordinate of this point of intersection to the horizontal 
axis, we draw the horizontal line segment from the point of intersection to the 45-degree line. Now, from the 
45-degree line we draw the vertical line segment to the horizontal axis. Now that we are back on the 
horizontal axis, we repeat the previous step over again to find the next point in the orbit, and so on. 

Ranges: The relevant dynamics of Logistic MAP take place for the values of the parameter a between 0.0 
and 4.0, and the x1 variable between 0.0 and 1.0. The choice of the initial condition on the unit interval is not 

important since almost all orbits eventually behave about the same. The value of the parameter a, however, is 
crucial for the asymptotic dynamics, as we will see momentarily. 

»> Equation -> MAP Library -> Logistic MAP: 
From the Equation menu, select MAP Library and then pick Logistic MAP. Now the current 
equation is Logistic MAP as seen on the banner. 

»> View -> 1-D Stair Stepper: 
From the View menu, select 1-D Stair Stepper to make this view the current view. Again, 
note the current equation and the current view names on the banner. 

»> Numerics: 
Click on the Numerics button on the button bar to open the Numerics Editor. 

»> Window Size: 
Notice that the Numerics Editor automatically displays the tree of the Current View. From the tree, 
select Window Size. By clicking on the text fields, set X-Min = -0.1, X-Max = 1.1, Y-Min = -
0.1, and Y-Max = 1.1. Apply. 

»> Parameters: 
Click on the Parameters button on the button bar of the Numerics Editor. Set the value of the 
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parameter a = 2.8. Apply. 

»> Go: 
Click on the title bar of the Main Application Window to bring the Current View to the foreground. 
Press Go to see the Stair Step diagram drawn. 

»> Current View -> Graphics -> Graph Plotting Repaint Interval Delay (ms): 
To see how this picture really developed, let us recreate it in slow motion. For this purpose, return to 
the Numerics Editor and click on the Current View button and choose Graphics from the 
control tree. Set the Graph Plotting Repaint Interval Delay (ms) to 1000. Apply. 
Phaser will pause 1000 milliseconds between two plotted points. Depending on the speed of your 
computer, you might want to adjust the delay time. 

»> Clear and Go: 
Return to the Main Application Window and hit Clear and Go. The graph of the logistic function 
should appear immediately, but the successive points on the computed orbit should appear at a 
speed that allows you to follow the dynamics: The orbit converges to a fixed point. Notice that the 
fixed point is the intersection of the 45-degree line with the graph of the function. 

»> Graph Plotting Repaint Interval Delay (ms): 
Set Graph Plotting Repaint Interval Delay (ms) to 1, to speed things up again. 
Apply. 

»> Parameters: 
Set a = 3.4. Apply. 

»> Clear and Go: 
The orbit no longer approaches the fixed point. Where does it go? 

»> Time: 
Return to the Numerics Editor and click on the Time button. To discard the transient (early) part of 
the orbit, set Start Plotting to 333 and Stop Plotting 3333. Apply. 

»> Clear and Go: 
The orbit approaches a periodic orbit of period 2. This qualitative dynamical change where a fixed 
point gives up its stability to a periodic orbit of period 2 is called a period-doubling bifurcation. 

»> Parameters: 
Set a = 3.55. Apply. 

»> Clear and Go: 
You should now see a periodic orbit of period 4. This is another period-doubling bifurcation. 

»> Parameters: 
Set a = 4.0. Apply. 
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»> Clear and Go: 
You should now see the orbit nearly fill the view - Chaos. 
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Lesson 4. Bifurcation Diagram of Logistic MAP 

In this lesson, we will show how to compute the bifurcation diagram of the Logistic MAP 

 
This diagram will depict one of the most famous routes to chaos through successive period-doubling 
bifurcations as the parameter a is varied. 

Bifurcation diagram: Here is how a bifurcation diagram is computed. One of the parameters in the 
definition of the current equation is assigned to the X-Axis, and one of the variables xi is assigned to the Y-

Axis. Then the parameter range, determined by X-Min to X-Max, is divided into a number of specified 
subdivisions. For each parameter value in this subdivision, the orbits are computed and plotted using the 
current settings of Initial Conditions, Time, and Algorithm. 

»> Equation -> MAP Library -> Logistic MAP: 
From the Equation menu, select MAP Library and then pick Logistic MAP. 

»> View -> Bifurcation Diagram: 
From the View menu, select Bifurcation Diagram to make this view the current view. 
Notice the current equation and the current view names on the banner. 

»> Numerics: 
Click on the Numerics button on the button bar to open the Numerics Editor. Notice that the 
Numerics Editor automatically displays the tree of the Current View. 

»> Bifurcation Diagram: 
The root of the control tree of the Current View is also called Bifurcation Diagram. Let us 
examine the contents of the root. Notice that the parameter a is assigned to the X-axis and the 
variable x1 is assigned to the Y-axis. Since there is only one parameter and the equation is one 
dimensional, there are no choices to be made. Parameter Sample Size is set to 250; thus, 
there will be 250 parameter subdivisions in the computation of the bifurcation diagram. 

»> Window Size: 
From the tree, select Window Size. By clicking on the text fields, set X-Min = -0.1, X-Max = 
4.1, Y-Min = -0.1, and Y-Max = 1.1. Apply. Thus, 250 equally spaced values of the parameter a in 
the range from -0.1 to 4.1 will be used. 

»> Initial Conditions: 
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Click on the Initial Conditions button. There is only one active set which is 0.2 at time 0.0. This is 
fine, since almost any initial condition between 0.0 and 1.0 gives the same bifurcation diagram. 

»> Time: 
Click on Time on the button bar and set Start Plotting to 999 and Stop Plotting to 
2222. Apply. With these numbers, we discard the first 999 iterates and record the limiting behavior 
of solutions. Why these numbers? Well, they are easy to type with one finger. 

»> Go: 
Now, click on the title bar of the Main Application Window to bring it to the foreground and press 
Go. Bifurcation diagram should gradually come to life. 

»> Parameter Sample Size: 
Let us increase the resolution of the bifurcation diagram. Return to the Numerics Editor and click on 
the Current View button. Then click on the root of the tree, Bifurcation Diagram . Now 
press the drop-down choice widget to the left of Parameter Sample Size and set it to 500. 
Apply. 

»> Clear and Go: 
A finer bifurcation diagram. 

Period-doubling cascades: It is visible in the bifurcation diagram that for the parameter values until 3.0, the 
orbit is attracted to a fixed point. The location of the fixed point changes as the parameter is varied. When the 
parameter is increased past 3.0, the fixed point gives up its stability to an asymptotically stable periodic orbit 
of period 2. This bifurcation is known as a period-doubling bifurcation. As the parameter is increased further, 
the orbit undergoes successive period-doubling bifurcations and eventually becomes non-periodic. 

Period three: Notice that there are also some dark gaps in the bifurcation diagram. For example, the largest 
gap contains a periodic orbit of period 3. Let us now enlarge a portion of the bifurcation diagram to reveal 
some of its fine structure. 

»> IC: 
The choice button in the center of the Tool Bar is a mouse action selector. IC indicates that the 
current mouse function is for setting Initial Conditions. Click on the drop-down widget next to IC in 
the middle of the Tool bar and select ZOOM. 

»> ZOOM: 
In the ZOOM mode, the mouse can be used to zoom into a selected region of the graphical view or 
to zoom out by a chosen factor. The default setting is to zoom in and we shall leave it unchanged. 
Notice that the cursor inside the view is changed. Now, position the cursor near X = 3.75 and Y = 
1.0. You can see the coordinates of the current cursor location in the left portion of the Tool Bar. 
Click the left mouse button and release it. Next, move the cursor to the location X = 3.9 and Y = 
0.09. Notice the rubber band marking the selected rectangle. Click the left mouse button again. The 
enlargement of the selected region of the Bifurcation Diagram should be underway automatically. 
Notice the period-three orbit in the middle. 
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»> ZOOM: 
The period-three orbit appears to undergo a sequence of period-doubling bifurcations as well. To 
see this phenomenon more clearly, let us zoom into the middle portion of the bifurcation diagram. 
Now, position the cursor near X = 3.838 and Y = 0.58; click the left mouse button and release it. 
Next, move the cursor to the location X = 3.857 and Y = 0.39; click the left mouse button again. The 
enlargement of the selected region of the Bifurcation Diagram should be underway automatically. It 
is remarkable that this bifurcation diagram looks much like the first one we plotted. 
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Lesson 5. Phaser Projects 

During simulations, current state of Phaser (numerical and graphical settings of all things) can be saved to a 
small user-specified file by simply using Save Current Project button on the File menu of the 
Main Application Window. A previously saved Phaser Project file can be reloaded into Phaser using Load 
Phaser Project button on the same menu. This action restores the current state of Phaser to that of the 
saved project. 

A more important function provided in Phaser is the ability to load previously saved Phaser Project files over 
the net using Load Phaser Project URL button on the File menu of the Main Application Window. 
This action enables you to Fetch the desired Phaser Project file using http protocol: http://< file 
location > . 

In this lesson, we will load a Phaser Project file modeling reversals of earth's magnetic field from the Web 
site of Phaser. We assume that you are connected to the internet. 

»> File -> Load Phaser Project URL: 
From the the File menu of the Main Application Window, choose Load Phaser Project 
URL. A dialog box should pop. 

»> http://www.phaser.com/projects/rikitake3.ppf 
Click in the text field of the dialog box and type the URL address above. We have deposited this 
project file rikitake3.ppf at this location. 

»> Fetch: 
Now hit the Fetch button. The dialog box should disappear and the project should load. As soon as 
the loading is finished, two orbits of a three-dimensional ODE named Rikitake Disc 
Dynamos ODE should begin to appear. 

»> Equation -> View Current Equation: 
To see the text of the equations, select View Current Equation entry from the Equation 
menu of the Main Application Window. These equations describe the motion of two coupled disc 
dynamos. The variables x1 and x2 are (scaled) currents of the two dynamos. The parameter m is a 

function of the self-inductance, resistance, mutual inductance, and the driving torque of the 
dynamos, and the parameter a is the (scaled) difference of the angular velocities of the dynamos. 

»> File -> Open Phaser Project Notes : 
A Phaser Project File (.ppf) comes with a text file containing notes about the current project. To 
view the Notes for the current project, from the File menu, select Open Phaser Project 
Notes. 

»> 3-D: 
Notice that the mouse is in 3-D mode as indicated on the tool bar. While pressing down the left 
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mouse button, you can move the mouse around to rotate the three-dimensional orbits to get more 
informative pictures. 

»> View -> Xi vs Time: 
From the View menu of the Main Application Window, select Xi vs Time. Press Go to see the 
x1 vs Time plots of the two solutions. This is a revealing picture. Since x1 is the current through the 

first dynamo, a change in sign of x1 corresponds to a reversal of the current and hence a reversal in 

the polarity of the magnetic field. Notice the non-periodic - chaotic - reversals of sign of x1. 

»> Equation -> Import Custom Equation: 
If you are interested in exploring Rikitake Disc Dynamos ODE further at a later time, you 
can import the equations into your private Custom library. Simply, choose the entry Import 
Custom Equation from the Equation menu. (If the equation is already in the Custom Library, 
the menu entry will be grayed out.) 

»> File -> Save Current Project As...: 
You can also save the current imported project locally on your computer by selecting Save 
Current Project As... from the File menu of the Main Application Window. Now that the 
imported project is safely saved, you can change the settings to explore the dynamics. For example, 
set the parameter m = 0.5 to see periodic oscillations of the currents. Now, you can return to the 
Phase Portrait view, and Clear and Go, to see the three-dimensional picture of the periodic 
oscillations. 

Further mathematical details on the Rikitake two-disk dynamo system can be found in Cook and Roberts 
[1970] and Robbins [1977]. Information about dynamos and earth's magnetism is available at http://
www-spof.gsfc.nasa.gov/earthmag/dynamos.htm 
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Lesson 6. The Gallery 

In this lesson, we will investigate certain bifurcations in the dynamics of the area-preserving Cremona MAP 

 
by plotting phase portraits as we vary a parameter. We will organize these phase portraits into a gallery of 
iconic images and manipulate them. 

»> Equation -> MAP Library -> Cremona MAP: 
From Equation menu, select MAP Library. From the list, select Cremona MAP. 

»> Equation -> Load Equation Defaults: 
Again from Equation menu, select Load Equation Defaults. Now all settings will be 
loaded from a system file which contains values yielding an informative picture. In particular, the 
equation parameter is set to a = 1.32843. You should now see a phase portrait of Cremona 
MAP consisting of about a dozen initial conditions iterated 1500 times. 

»> View -> Send View to Gallery: 
From View menu of the Main Application window, select Send View to Gallery. The 
contents and the associated settings that are necessary to recreate this phase portrait will be sent to 
the Gallery. 

»> Phaser -> Gallery: 
To see where the phase portrait is deposited, select Gallery from Phaser menu of the Main 
Application window. The co-primary window Gallery should pop. Gallery currently consists of four 
frames and the phase portrait is deposited in the first frame. 

»> Parameter: 
From Numerics Editor, set the parameter value to a = 1.56. Apply, return to Main Application 
window, and Clear and Go. Now, you should see the phase portrait of Cremona MAP for the new 
value of the parameter. 

»> View -> Send View to Gallery: 
To deposit the new phase portrait into Gallery, select Send View to Gallery. Notice now 
that the new phase portrait is deposited in the next available frame. 
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»> Two more frames: 
Next, set the parameter to a = 1.92. Apply, Clear and Go, and Send View to Gallery. Repeat 
with a = 2.0. All four phase portraits should now be deposited in Gallery. 

»> Send to a Selected Frame: 
Let us now change the contents of a selected frame. First, select the second frame (1, 2), making 
sure that its boundary is red. Return to Numerics Editor and change the parameter value to a = 
1.61. Apply and Clear and Go. Then click on Send View to Gallery. Now, the contents of 
the Phase Portrait view will be resent to the second frame. Unselect the second frame by clicking in 
it. 

»> Animate: 
Now, click on the Animate button on the button bar of Gallery. The frames should be played 
sequentially in the Main Application window. 

»> File -> Open Gallery Project Notes: 
From the File menu of the Gallery co-primary window, select Open Gallery Project 
Notes. In the spawned small window, you can type in a description of the Gallery you have just 
created. When the current Gallery is saved, these notes are saved along with the images. 

»> File -> Save Current Gallery: 
Finally, you can save the current Gallery in a file using Save Current Gallery entry on the 
File menu of the Gallery co-primary window. 
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Lesson 7. Custom Library: Entering new equations 

Phaser provides an easy-to-use Equation Editor with a graphical interface for adding new equations to 
the library. Once entered successfully, a new equation is deposited into the Custom Equation Library of 
PHASER and is indistinguishable, as far as the user is concerned, from the Permanent Library equations. 
Previously added user-defined equations can also easily be modified or deleted. 

Phaser is designed for first-order ordinary differential (ODE) or difference (MAP) equations. A higher-order 
equation should first be converted to a system of first-order equations. 

In this lesson, we will use the pendulum equations to illustrate the process of entering a new equation into 
PHASER: 

   x1' = x2 
   x2' = -(g / l) sin(x1) - (c / (l m)) x2 

where g, l, c, and m are parameters. 

»> Equation -> Add Custom Equation: 
From the Equation menu on the menu bar of the Main Application window, choose Add 
Custom Equation. The new window that pops is the Equation Editor co-primary 
window for adding a new equation. In the remainder of this tutorial, we will populate the requisite 
fields in the Equation Editor. 

»> Equation Name: 
Each new equation must be named. Let us call our new equation My Pendulum ODE. Click on 
the text field and type this name. By convention, we recommend the usage of the suffix ODE to tag 
an ordinary differential equation, and MAP to tag a difference equation. 

»> Equation Description (optional): 
This field holds an optional descriptive sentence of the equation and is not used by Phaser. Click on 
the text field and type, for example, Practicing how to enter a new equation. 

»> Equation Type: 
Library equations are sorted into two types: ODE and MAP. Since My Pendulum ODE is ODE, 
we need not change the type. If you were entering a difference equation, from the drop-down 
widget, you would choose MAP. 

»> Default Algorithm: 
Each equation is provided with a default algorithm. The current default algorithm for ODE type is 
Dormand-Prince 5(4), which is fine for our equation. The drop-down widget contains other 
ODE algorithms. 
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»> Parameter Name: 
Our equation has four parameters: g, l, c, and m. We need to tell Equation Editor about these 
parameters and their default values. Any single lower- or upper-case letter, except t, x, and E, 
which are reserved for time, space, and the famous constant, can be used as a parameter. Click on 
the text field and type g. 

»> Parameter Value: 
Click on the text field and enter 1.0. This is the default value of the parameter g. 

»> Add Parameter: 
Click on this button to add the parameter g and its default value. Now the Parameter List field 
should show g = 1.0. 

»> Repeat three steps: 
Now repeat the previous three steps with the remaining three parameters until Parameter List shows 
g = 1.0, l = 1.0, c = 0.0, m = 1.0. 

»> Parameter Editing: 
To change the name or the default value of a parameter, click on it in Parameter List and 
change things as desired; re-add parameter. To remove a parameter from Parameter List, highlight 
the desired parameter by clicking on it and then push the Remove Parameter button. 

»> x1' = : 
Click on the text field and type x2. This is the right-hand side of the first equation. 

»> x1 = : 
This is the default initial value of the variable x1. Click on the text field and type 1.5. The initial 
displacement is 1.5. 

»> x2' = : 
To activate this field, first click on the button to the left of x2' =. This should highlight the text field 
for x2'. Now, click on the text field and type -(g / l) * sin( x1 ) - (c / (l * 
m) ) * x2. 

»> x2 = : 
This is the default initial value of the variable x2. We can leave it alone - zero initial velocity. 

»> Add: 
Finally, click on the Add button to add your new equation to the Custom Library of Phaser. At this 
point, Phaser attempts to parse the expressions for x1' and x2'. Barring some typographical errors, 
Equation Editor should report in Status Field that expressions are parsed and the new equation is 
added. If it fails to parse, correct the offending errors and Add again. 

»> Close: 
Now, you can safely Close Equation Editor from the File menu of the Editor. 
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»> Viewing Current Equation: 
From the Equation menu of the Main Application window select Custom Equation 
Library. Click on My Pendulum ODE to make it the current equation. Finally, from the 
Equation menu, select View Current Equation. A small window containing the text of 
My Pendulum ODE should pop. Examine the text carefully before embarking on computations. 
You can correct any typographical errors using the Modify Custom Equation entry of the 
Equation menu. 

Parser Syntax: x1, x2, ..., x24 are special tokens and must be written exactly and without spaces. For 
detailed specifications on the operators, operands, and functions supported by the parser, you can consult 
Phaser: Equation Editor in the Table of Contents of Phaser Help. For your convenience, this page 
can be directly accessed by choosing Help Contents from the Help menu of Equation Editor. 

Speed: A user-entered equation runs approximately at half the speed of its compiled counterpart. If you like, 
now you can check out the speed and the accuracy of Phaser's parser/evaluator by running a computation 
with the compiled equation Pendulum ODE and its parsed counterpart My Pendulum ODE. 
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Lesson 8. Flow box 

In this lesson we will investigate the dynamics of Cremona MAP 

 
by following the fates of 10,000 solutions starting from randomly chosen initial conditions in a selected box. 

Cremona MAP is a two-dimensional area-preserving map. Near fixed or periodic points of an area-preserving 
map, two distinct dynamical behaviors prevail: 

●     elliptic: Near an elliptic point, solutions usually rotate along closed invariant curves. A box about 
an elliptic point rotates, albeit distorted, as it moves under the iterations of the map. 

●     hyperbolic: Near hyperbolic points, some solutions move towards the point while others move 
away. Consequently, a box about a hyperbolic point is stretched along one direction while being 
contracted along another. Since the area of the box must be preserved, the box can undergo 
remarkable topological changes under the iterations of the map. 

In this lesson, we will explore these two types of dynamical behavior in Cremona MAP. 

»> Equation -> MAP Library -> Cremona MAP: 
From the Equation menu on the menu bar, select MAP Library. From the list of MAPs, select 
Cremona MAP. This is an are-preserving map on the plane. 

»> Equation -> Load Equation Defaults: 
From the Equation menu on the menu bar, select Load Equation Defaults. You should 
see phase portrait of Cremona MAP. 

»> Numerics: 
Click on the Numerics button on the button bar to open the Numerics Editor. 

»> Graph Plotting Repaint Interval: 
From the drop-down choice widget next to Graph Plotting Repaint Interval, choose 
1. Apply. Now, the graphical view will be updated after each iteration. 
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»> Graph Repaint Interval Delay (ms): 
To see the evolution of the pictures we are about to plot, it is necessary to introduce a time delay 
into plotting. Depending on the speed of your computer, you should adjust this setting (an integer) 
to get the desired effect. For example, set Graph Repaint Interval Delay (ms) to 500. 
Apply. 

»> Stop Plotting: 
Select the Time button on the button bar of the Numerics Editor, and set Stop Plotting to 100. 

»> Phaser: 
Click on the action button Phaser to return to the Main Application window. 

»> Flow: 
From the drop-down choice widget next to IC on the tool bar of the Main Application window, 
select FLOW. Now the mouse function will be to select a flow box. 

»> Number of random initial conditions: 
From the drop-down choice widget next to Number of random initial value points 
in the flow box select 10,000. (For a slow CPU, this number should be smaller.) 

»> Flow box coordinates (elliptic): 
Move the cursor to coordinates about (-0.15, 0.15) and click and release left mouse button. Move 
the cursor to about (0.15, -0.15) and click and release left mouse button. Now, from 10,000 
randomly chosen initial conditions in this square, solutions will be computed and displayed at each 
iteration. You should see the image of a red square under iterations. Since this square is in the 
region near the origin dominated by elliptic dynamics, the square should rotate under the iterations 
in a somewhat distorted manner. 

»> Clear: 
While the picture is evolving, occasionally press Clear button on the button bar of the Main 
Application window. You should see the current state of the original square. (You can Stop the 
computations any time.) 

»> New flow box coordinates (hyperbolic): 
Move the cursor to coordinates about (-0.42, 0.42) and click and release left mouse button. Move 
the cursor to about (-0.30, 0.30) and click and release left mouse button. Now, from 10,000 
randomly chosen initial conditions in this box, solutions will be computed and displayed after each 
iteration. You should see the image of a red box under iterations. 

Since this box is in the region dominated by hyperbolic dynamics of a period-5 point, the box 
should rotate under the iterations and visit the vicinity of five periodic points. After a few iterations, 
the original box should start spreading into a complicated geometry. Indeed, the dynamics near this 
hyperbolic periodic orbit of saddle type is chaotic. 

»> Clear: 
While the picture is evolving, occasionally press Clear button on the button bar of the Main 
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Application Window. You should see the dramatic current state of the original square. 

Suggestions for further explorations: Cremona MAP undergoes interesting bifurcations as the parameter a 
is varied. In the Lesson on Gallery, we explore the dynamics as the parameter a passes through 2pi/3 
(approximately 2.0943951). 

Another nice use of Flow is to explore the phase portrait of Pendulum ODE while changing the friction 
coefficient from c = 0 to c = 0.5. 
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Lesson 9. Cloning Current Phaser 

In this lesson, we will iterate the Logistic MAP 

   x -> 4x(1 - x) 

and the Logistic III MAP 

   x -> 4x - 4x2 

100 times using the Initial Condition x = 0.2. Notice that the these two maps are mathematically the same. To 
the computer, however, they are rather different, as the numbers will reveal. For ease of comparison of 
numbers, we will clone Phaser and carry out computations using two distinct copies of Phaser. 

We first customize Phaser to compute the desired numbers with the Logistic MAP. 

»> View: 
From the View menu of the Main Application Window select Xi Values. Now the current view 
is set to Xi Values which is the appropriate view for tabulating numerical values of solutions. 

»> Equation: 
From the Equation menu on the menu bar, select MAP Library. From the list of MAPs, select 
Logistic MAP. 

»> Viewing Current Equation: 
From the Equation menu, select the last entry View Current Equation. A small window 
containing the text of Logistic MAP, x -> ax(1 - x) should pop. 

»> Numerics Editor: 
Click on the title bar of the Numerics Editor to bring it to the foreground. 

»> Parameters: 
Click on the Parameters button on the button bar of the Numerics Editor. Set a = 4.0 and Apply. 

»> Initial Conditions: 
Click on the Initial Conditions button on the button bar of the Numerics Editor. Notice that 
there is one set of initial conditions activated with the default values t = 0.0 and x1 = 0.2. These 

values happen to be what we want; so we will not touch them. 

»> Time: 
Click on the Time button on the button bar of the Numerics Editor and set Stop Plotting to 
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100, and Apply. 

»> Current View: 
Click on Current View on the button bar of Numerics Editor and set # of Last Xi 
Values to View to 100. Apply. 

»> Phaser: 
Click on Phaser action button to bring the Main Application Window to the foreground. 

»> Go: 
Now click on the Go button on the button bar of the Main Application Window to see the results. 
You can use the slider on the right to browse through the 100 iterates. 

Now, we clone an additional copy of Phaser with the settings above. The clone is labeled PHASER [1], and 
we will use the label [1] to tag the actions in this copy. 

»> Clone Current Phaser: 
From File menu of the Main Application Window, select Clone Current Phaser. A new 
copy of Phaser with all the current settings, such as Equation, Parameters, Current View, etc., 
should spawn. Notice that the Clone Phaser is tagged with PHASER [1] on its title bar. Click on 
Numerics on the button bar of PHASER [1] to spawn Numerics Editor [1]. 

»> Equation [1]: 
From the Equation menu of the Clone PHASER [1], select MAP Library and then Logistic 
III MAP. 

»> Numerics [1]: 
Click on the Numerics button of PHASER [1] to bring the Numerics Editor of the clone. 

»> Parameters [1]: 
Click on the Parameters button on the button bar of the Numerics Editor [1]. Notice that a = 4.0. 

»> Initial Conditions [1]: 
Click on the Initial Conditions button on the button bar of the Numerics Editor [1]. Notice 
that there is one set of initial conditions activated with the default values t = 0.0 and x1 = 0.2. 

»> Go [1]: 
Click on the Go button on the button bar of PHASER [1] to see the 100 iterates of the initial 
condition x1 = 0.2 under the Logistic III MAP. 

Now, using the sliders of the Xi-Values views of the two Phasers, examine the numbers and try to determine 
when they begin to diverge. Do you prefer one set of numbers over the other? 

41



Lesson 10. Real-time 3-D Graphics 

When the current equation is of dimension three or higher, the Phase Portrait view is configured for 3-D 
Graphics functionality. Some of the key points to note are: 

●     If the current equation is of dimension four or greater, you can select any three-dimensional 
orthogonal projection to view. 

●     Remember that the computed points will be saved in memory, so be aware of number of points 
generated by looking at Time and Step Size. 

●     If your computer has a slow CPU or small memory, you can disable interactive 3-D rotations by 
unchecking Real-Time Rotation & Animation from Real-Time on the control tree of 
the Phase Portrait view. 

●     Notice that the mouse function is set to 3-D and radio buttons are added to the Tool Bar. 
●     After hitting Go, you can grab the image in the view with the mouse by holding down the left mouse 

button and spin the image around, or use the radio buttons for special rotations. 
●     You can stop rotations only from the radio button [] for stop on the Tool Bar. 

In this lesson we will use the four-dimensional system of ODEs 

 
stored in the library of Phaser under the name Harmonic Oscillators ODE to illustrate several basic 3-
D graphical utilities of Phaser. A typical orbit of this system winds around a two-dimensional torus in four-
dimensional space. Three-dimensional orthographic projection (plotting the first three variables) of these 
orbits wind around cylinders. Below, we will draw two such orbits in 3-D and rotate them in real time. 

»> Equation -> ODE Library -> Harmonic Oscillators ODE: 
From Equation menu, select ODE Library and then click on Harmonic Oscillators 
ODE. 

»> Numerics: 
Press Numerics on the button bar to go to Numerics Editor. 

»> Phase Portrait: 
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Click on Phase Portrait at the root of the control tree. Notice that currently the x1 variable is 
assigned to the X-Axis, x2 variable to the Y-Axis, and x3 to the Z-Axis. These choices are fine. In 
dimensions greater than three, Phaser provides the facility to project onto a three-dimensional 
subspace from higher dimensions. Any three of the variables xi can be assigned to the X-, Y-, and Z-
axes for plotting. 

»> Window Size: 
From the tree, select Window Size.. Set X-Min = -3.5, X-Max = 3.5, Y-Min = -2.5, Y-Max = 
2.5, and Z-Min = -3.0, Z-Max = 3.0. Apply. 

»> Axes & Grids: 
From the tree, select Axes & Grids. Uncheck the buttons to the far left of Display Graph 
XY-Axes and Display Graph XY-Grid. Apply. Now the axes and grids will not be 
displayed on the Phase Portrait view. 

»> Connect Points: 
From the tree, select Graphics. Check the small box to the left of Connect Points. Apply. 
Now, two consecutive computed points on an orbit will be connected. 

»> Initial Conditions: 
Click on Initial Conditions. The first set of initial conditions is fine. To add a second set, 
click on the left-most square next to Set 2 and enter the values x1 = 0.5, x2 = 1.5, x3 = 0.5, x4 = 
1.5. Apply. 

»> Time: 
Click on the Time button and set Stop Plotting to 70.0. Apply. 

»> Plotting Step Size: 
Click on the Algorithms button and notice that the current algorithm is Dormand-Prince 5(4). 
Set Plotting Step Size to 0.05. Apply. 

»> Go: 
Now, return to the Main Application window and press Go. You should see two orbits being 
plotted. 

Using the current Step Size of 0.05, we have computed the solutions for 70 time units. Therefore, we have 
generated 1400 points per solution. Since Real Time Rotation & Animation is checked by default, 
these 2800 points have been saved. Now, we are ready to twirl them around. 

»> 3-D: 
Note that the mouse is set to be used for interactive rotations as indicated by 3-D in the center of the 
tool bar. Now, while the cursor is in the Phase Portrait view, the mouse will be used for rotating the 
contents of this view. Notice that the shape of the cursor is changed as a reminder of this new 
assignment. To rotate orbits, move the cursor into the view and grab the orbits by pressing and 
holding the left mouse button. While the mouse button is pressed, move the cursor around in the 
view to rotate the orbits in the desired direction. 
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»> Radio Button >: 
Now, hit the Radio Button > on the tool bar. The image should rotate continuously by itself at the 
speed of the last mouse drag. Watch the show. 

»> Radio Button []: 
Hit the Radio Button [] on the tool bar. The image should stop rotating. 

»> Radio Button X: 
Hit the Radio Button x on the tool bar. This is to request Phaser to rotate the image, from its last 
stopped position, about the X-Axis. 

»> Radio Button >: 
Hit the Radio Button > to start rotating the image about the X-Axis. 

»> Radio Button []: 
Hit the Radio Button [] on the tool bar. The image should stop rotating. 

We will continue manipulating these orbits in the next lesson. If you would like to interrupt this lesson now, 
you can save the current state of Phaser as follows: 

»> File -> Save Current Project: 
From File menu of the Main Application window, select Save Current Project. In the 
pop-up dialog box, type a file name (tutorial10.ppf) and hit Save. 
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Lesson 11. Poincare Map in 3-D 

This lesson is a continuation of the previous one. Here, we will slice the two orbits on cylinders with a 
specified plane and compute the points of intersections with the plane. 

The points of intersections of orbits of an ODE in three dimensions with a specified plane can be viewed as 
orbits of a map on the plane. This reduction of the dynamics of a three-dimensional ODE to a two-
dimensional MAP, called the Poincare map, is an important technique for investigating the dynamics of an 
ODE in three dimensions. 

If you have interrupted your lessons, you can first Load the Phaser project that you have saved at the end of 
the previous lesson as follows: 

»> File -> Open Phaser Project: 
From File menu of the Main Application window, select Open Phaser Project. In the pop-
up dialog box, click on the saved file name (tutorial10.ppf) and hit Open. 

»> Poincare: 
Return to Numerics Editor and select Current View button. From the control tree of the Phase 
Portrait view, select Poincare. 

»> Display Orbit Cut-Plane and/or Poincare Map: 
Click on the small square to the left of this item. Notice Orbit Cut-Plane Equation 1.0 
x + 0.0 y + 0.0 z + 0.0 = 0.0. The portion of an orbit on the positive side of this plane 
will be plotted in the color of its Initial Condition, while the portion on the negative side of the plane 
will be plotted in a darker shade of the same color. Cut-Plane Equation is in the unrotated coordinate 
system. Apply. 

»> Clear and Go: 
Two orbits in shades of blue and yellow should be visible. 

»> Display Poincare Map: 
Return to Numerics Editor and click on the small square to the left of this item. Now, in addition to 
the orbits, the points of intersections of the orbits with the specified plane will be plotted. Large red 
dots will mark the points when the orbits pierce the plane as they cross the plane from the negative 
to the positive side, and large yellow dots will mark the crossings from the positive to the negative 
side. The colors and the sizes of intersection points can be customized, as desired. Apply. 

»> Clear and Go: 
The two orbits and their points of intersections with the plane should be visible. Notice that the 
points are lined up along four lines. 

»> Plot Poincare Map Crossing Direction(s): 
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From the mathematical viewpoint, it may be necessary to plot the intersection points as orbits cross 
the plane in one direction only. To accomplish such a task, click on the drop-down choice widget 
and select Positive. Now only the intersection points as the orbits cross the plane from the 
negative side to the positive will be plotted. Apply. 

»> Clear and Go: 
The two orbits and their positive crossings, the red dots, should be visible. Notice that the crossings 
are lined up along two lines. 

»> Orbit Cut-Plane Equation: 
Modify the text fields for the coefficients of Cut-Plane Equation to 0.0 x + 1.0 y + 0.0 z 
+ 0.0 = 0.0. Now, the orbits will be cut and the Poincare map will be computed using this new 
plane. Apply. 

»> Clear and Go: 
The two orbits and their positive crossings with the new plane, the red dots, should be visible. 
Notice that the crossings are lined up along two circles. 

»> Initial Conditions: 
If only the intersection points, Poincare map, is desired, we can set the colors of Initial Conditions to 
the background color. Set the colors of the Initial Conditions to black. Apply. 

»> Clear and Go: 
Now, only the positive crossing points along two circles should be visible. 
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Lesson 12. Poincaré Map of Forced Duffing ODE 

In this lesson we will compute the Poincaré, or the period, map of the periodically forced Duffing's oscillator 
given by the equations 

 

Periodically forced oscillators occupy a prominent place in applied dynamical dynamical systems. The 
technique we will employ in this lesson is applicable to other forced equations such as Forced 
Vanderpol ODE and Forced Bridge ODE. 

The solutions of a periodically forced equation are invariant under translations in time by the period of the 
forcing term. Thus the qualitative dynamics of solutions can be studied by plotting the values of the solutions 
once every period. The resulting planar map is called the Poincaré or the period, map. If the Poincaré map of 
a solution approaches a fixed point, then the solution must be periodic with the same period as the period of 
the forcing term. If, however, the Poincaré map wanders in a bounded region without ever repeating itself 
then the solution must be non-periodic, or chaotic. 

To compute the Poincaré map numerically, we take a step size an integer multiple of which is the period (in 
this example, the period of the forcing term is 1/d). Then simply plot the solution only at the integer multiples 
of the period. 

»> Equation -> ODE Library -> Forced Duffing ODE: 
From the Equation menu, select ODE Library and then pick Forced Duffing ODE. 

»> Equation -> View Current Equation: 
From the Equation Menu select the entry View Current Equation to see the text of the 
Forced Duffing ODE. 

»> View: 
The current view should be the Phase Portrait view. 

»> Parameters: 
Click on the Parameters button on the button bar of the Numerics Editor. Set the value of the 
parameters a = 1.0, b = 0.3 and c = 0.3, d = 0.2. Apply. 
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»> Initial Conditions: 
Click on the Initial Conditions button on the button bar of the Numerics Editor. Notice that 
Set 1 is t = 0.0, x1 = 1.2 and x2 = 1.7, which is fine. To activate Set 2 click on the small button to 
the left of Set 2 and set t = 0.0, x1 = -1.2 and x2 = 1.7. Apply. 

»> Window Size: 
Click on the Current View button. From the tree of the Current View, which is Phase Portrait, 
select Window Size. By clicking on the text fields, set X-Min = -2.0, X-Max = 2.0, Y-Min = -
1.5, and Y-Max = 1.5. Apply. 

»> Time: 
Click on the Time button. To discard the transient (early) part of the orbit, set Start Plotting 
to 66 and Stop Plotting to 333. Apply. 

»> Go: 
Bring the Phase Portrait view to the foreground by clicking on the title bar of the Main Application 
Window. Now hit Go to see two solutions, the first one in blue and the second in yellow. Notice that 
both solutions are periodic. 

»> Algorithms: 
Click on the Algorithm button on the button bar of Numerics Editor. Notice that the current 
algorithm is Dormand-Prince 5(4). The current Plotting Step Size is set to 0.01. The 
choices of the Algorithm is fine for the present calculations. 

Now, we will prepare for the computation of the Poincaré map. Since the parameter d is set to 0.2, 
the period of the forcing term is 5.0. To get the Poincaré map, all we need to do is set Plotting 
Step Size to 5. Apply. 

»> Clear and Go: 
Bring the Phase Portrait view to the foreground and press Clear and Go. Notice that there are two 
blue dots on the right and two yellow dots on the left. Thus, both solutions are periodic with period 
twice the period of the forcing term. 

»> Graphics: 
To give these important dots a bit more prominence, return to the Numerics Editor and select 
Current View. From the control tree, select Graphics. The first entry on the right is 
Graph Point Size. Click on the drop down widget and select 2. Apply. 

»> Clear and Go: 
Now, you should see the same pairs of dots plotted in larger point size. 

As the parameters are varied, the dynamics of Forced Duffing ODE can undergo remarkable changes. 
Indeed, for certain parameter values the system exhibits visible chaos. 

»> Parameters: 
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Return to the Numerics Editor and change the value of the parameter b to 0.2. Apply. Note that the 
period of the forcing remains unchanged so we can use the current setup to compute the Poincaré 
map. 

»> Time: 
Click on the Time button and set Stop Plotting to 4444. Apply. 

»> Clear and Go: 
Now you should see many blue and yellow dots sprinkled around with no discernible pattern. This 
set is an example of a strange attractor. 

»> Plotting Step Size: 
To see the actual solutions, rather than the Poincaré map, click on Algorithms button on the 
Numerics Editor and set Plotting Step Size to 0.02. Apply. 

»> Clear and Go: 
These are non-periodic (chaotic) solutions of Forced Duffing ODE. You can hit Stop if you have a 
slow computer. 
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Lesson 13. Sequencing Slides 

In this lesson, we will learn how to create a sequence of slides. We will use Sierpinski-Knopp 
(IFS) MAP to create nine slides picturing fractal curves with fractal dimesions ranging from 1 to 1.8 with 
increments of 0.1 

»> Equation -> MAP Library -> Sierpinski-Knopp (IFS) MAP: 
From Equation menu, select MAP Library. From the list, select Sierpinski-Knopp 
(IFS) MAP. 

»> Equation -> Load Equation Defaults: 
Again from Equation menu, select Load Equation Defaults. (You can also simply type 
l as a keyboard shortcut to load equation defaults.) Now, values of all settings will be loaded from a 
system file resulting in a nice fractal curve. 

»> Phaser -> Numerics -> Parameters: 
From Phaser menu of the Main Application window, select Numerics -> Parameters to 
bring up the panel of the Numerics Editor containing the parameter settings. Notice that the equation 
parameter is set to d = 1.7097. Parameter d is the dimension of the fractal curve. 

»> d = 1.0   [x] Sequence, using delta 0.1: 
Set d = 1.0, check the Sequence box, and type 0.1 for the increment value delta. Apply. 
Return to Phaser main application window. 

»> Phaser -> Gallery: 
From Phaser menu of the Main Application window, select Gallery. The co-primary window 
Gallery should pop. Gallery currently consists of four empty frames. 

»> Gallery -> Size -> 3x3: 
From Gallery menu of the Gallery co-primary window, set the gallery size to 3x3. Now, you 
should see 9 empty frames in the Gallery. 

»> Sequence: 
Click on the Sequence button on the Button Bar of the Gallery window. Now, each frame in the 
Gallery should be populated with fractal curves with increasing fractal dimension. 

»> Slideshow: 
Click on the Slideshow button on the Button Bar of the Gallery window. Now, a new window for 
playing slide shows should spawn. Click on the Play button to see the slide show. Adjust the speed 
as you desire, or play it in a loop. 

»> Save Current Gallery: 
You can save the current Gallery in a file using Save Current Gallery entry on the File 
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menu of the Gallery co-primary window. 

»> Serialize Gallery Images to Disk: 
Slides can be saved to disk as a sequence of graphics files using Serialize Gallery 
Images to Disk on the File menu of the Gallery window. Once saved, these images can be 
further processed using, for example, QuickTime. 
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